Slow backend responses

Major incident Cloud - EU
2022-06-05 16:30 CEST · 7 hours, 13 minutes

Updates

Resolved

Our backend services suffered from decreased storage performance, resulting in overall performance degradation.

This issue has been remediated and all services are fully operational again.

June 5, 2022 · 23:43 CEST
Investigating

Our backend services are experiencing a slowdown and we are actively investigating the root cause. An update will follow as soon as possible.

June 5, 2022 · 21:22 CEST

← Back